phpmyadmin 配置文件中的密文(blowfish_secret)太短的解决方法
2017-03-19 13:41:22   来源:    点击:

昨天折腾了一个晚上的服务器,反复的安装、回滚,最后还是没能把原来的数据正常的导入到版本的MYSQL里,最终只好把PHP与Nginx升级了事,顺便也把phpmyadmin升级了,但登录到phpmyadmin后却出现“配置文件现在需要

昨天折腾了一个晚上的服务器,反复的安装、回滚,最后还是没能把原来的数据正常的导入到版本的MYSQL里,最终只好把PHP与Nginx升级了事,顺便也把phpmyadmin升级了,但登录到phpmyadmin后却出现“配置文件现在需要绝密的短语密码(blowfish_secret)”这样的错误提示,这又是为何呢?经过一番查询,原来是默认的config.inc.php里面的$cfg['blowfish_secret']是空的。

既然知道了问题所在就好解决了,到phpmyadmin的安装目录里面找到config.inc.PHP文件,用文本软件打开,找到“$cfg['blowfish_secret']=’ ‘”语句。

phpmyadmin 配置文件中的密文(blowfish_secret)太短的解决方法

在其单引号里面随便输入一些字符,然后保存。

好,再来看看问题解决了没有。

咦,登陆phpmyadmin还看到有红色的提示: 配置文件中的密文(blowfish_secret)太短。密文太短了?那要多长才行呢?再查询查询,原来新版本的phpmyadmin里config.inc.php的blowfish_secret 要一个32位以上的字符串才行,哦,原来如此,那就凑32个字符吧。

改好后重新登陆phpmyadmin,OK,终于没有红色的提示了,问题解决。

Tags:短语 密码 文件

上一篇:升级WordPress提示”另一更新正在进行”的解决方法
下一篇:最后一页